OpenGL 3.x renderer

A quieter space for design discussion of long-term projects
FluffyFreak
Posts: 1310
Joined: Tue Jul 02, 2013 1:49 pm
Location: Beeston, Nottinghamshire, GB
Contact:

Re: OpenGL 3.x renderer

Post by FluffyFreak » Sat Nov 22, 2014 1:25 pm

Progress made, decided to try the downloadable build, tada! It has exactly the problems described on the same machine that my own builds works on.

Looks like it might be due to MXE.

laarmen
Posts: 34
Joined: Fri Jul 05, 2013 8:49 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: OpenGL 3.x renderer

Post by laarmen » Wed Dec 03, 2014 4:43 pm

OK, I'm coming in a bit late in the discussion, but I didn't have time for Pioneer until now.

So, of course, I grabbed the latest of master, compiled (and had a coffee), and ran the thing without expecting much troubles. After all, I'm running it on a 2nd generation Intel Core integrated GPU, those buggers are fairly recent, they should have a fairly recent OpenGL version built-in, right? And those guys over at Mesa ain't lazy, so they've keeped up the pace and implemented the necessary bits, haven't they?

Turns out they haven't. My laptop cannot run anything higher than OpenGL 3.1.

So, I vote for 3.1 support. Were I the only one in the dev team unable to run current versions, I wouldn't mind, but since impaktor is stuck as well...

impaktor
Posts: 892
Joined: Fri Dec 20, 2013 9:54 am
Location: Tellus
Contact:

Re: OpenGL 3.x renderer

Post by impaktor » Wed Dec 03, 2014 7:11 pm

So, I vote for 3.1 support.
Latest master is already downgraded from 3.2 to 3.1, since #3265

laarmen
Posts: 34
Joined: Fri Jul 05, 2013 8:49 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: OpenGL 3.x renderer

Post by laarmen » Sat Dec 06, 2014 9:48 am

The API used might be 3.1 compliant, but we still ask for a 3.2 context. I've just submitted a PR to fix that, it is a trivial change but my mind would be more at peace if FluffyFreak would give his ACK.

FluffyFreak
Posts: 1310
Joined: Tue Jul 02, 2013 1:49 pm
Location: Beeston, Nottinghamshire, GB
Contact:

Re: OpenGL 3.x renderer

Post by FluffyFreak » Sun Dec 07, 2014 12:12 pm

Yep, I merged it in, stupid mistake by me.

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 1 guest